SNMP
The Simple Network Management Protocol (SNMP) is used in network management systems to monitor attached hardware for changes in operation activity. SNMP provides a standardized approach to monitoring and managing network systems.
For information on configuring your TMedia product to use the SNMP protocol, see the section labeled "Related Tasks".
TelcoBridges and SNMP
TelcoBridges offers support for SNMP versions 1, 2, and 3. This grants users the ability to remotely poll (or GET) system variables, known as Managed Objects, which are represented in files known as MIB modules. TelcoBridges currently offers polling on standard MIB modules (RTP, SONET, DS1, DS3, ISDN, etc...) and on the TelcoBridges privately defined module (TB-MIB).
Supported SNMP MIB modules
All tables of the RFC1213-MIB are supported, with the exception of:
ipRouteTable
EGP group
atTable
The following tables are supported:
ifTable
ifStackTable
The following tables of the DS1-MIB are supported:
Dsx1ConfigTable
Dsx1CurrentTable
Dsx1IntervalTable
Dsx1TotalTable
The following tables of the DS3-MIB are supported:
Dsx3ConfigTable
Dsx3CurrentTable
Dsx3IntervalTable
Dsx3TotalTable
The following tables of the SONET-MIB are supported:
sonetMediumTable
sonetSectionCurrentTable
sonetSectionIntervalTable
sonetLineCurrentTable
sonetLineIntervalTable
sonetFarendLineCurrentTable
sonetFarendLineIntervalTable
sonetPathCurrentTable
sonetPathIntervalTable
sonetFarendPathCurrentTable
sonetFarendPathIntervalTable
sonetVtCurrentTable
sonetVtIntervalTable
sonetFarendVtCurrentTable
sonetFarendVtIntervalTable
The following tables of the ISDN-MIB are supported:
isdnBearerGroup
isdnSignalingGroup
tbHwCommon
tbHwIdentTable (Hardware Identification)
tbHwVersionTable (Hardware Version)
tbHwTempTable (Hardware Temperature)
tbHwPowerSupplyTable (Hardware Power Supply)
tbHwFanTable (Hardware Fan)
tbSwCommon
tbFeatureTable (Software Features Supported)
tbSwVersionTable (Software Version)
tbSwPerfTable (CPU Usage)
tbSignaling
tbMtp2
tbM2pa
tbM2ua
tbM3ua
tbIua
tbIsdn
tbCas
tbSip
tbH248
tbCalls
tbNAP
tbHaNp1
tbHaApp
tbClock
SNMP IF-MIB ifTable interface type
The following table provides the interfaces type supported by TelcoBridges (IF-MIB ifTable described in RFC1573) with their corresponding description. The ifType are described in Internet Assigned Number Authority (IANA) in IANAifType-MIB
ethernetCsmacd(6)
Baseboard Ethernet interfaces
ds1(18)
Trunks Line Interface
ds3(30)
DS3 Line Interface
sonet(39)
SONET/SDH Line Interface
sonetPath(50)
SONET/SDH Line Service PATH (VC4/VC3/STS1/DS3)
sonetVT(51)
SONET/SDH Line Service SECTION (VC11/VC12/VT15/VT2)
isdn(63)
ISDN Stack
lapd(77)
ISDN LAPD Link (Primary)
lapd(77)
ISDN LAPD Link (Backup)
isdn(63)
IUA Link
isdn(63)
IUA Peer
lapd(77)
LAPD Link
ss7SigLink (156)
SS7 M2PA Link
ss7SigLink (156)
SS7 M2UA Link
ss7SigLink (156)
SS7 M2UA Peer
ss7SigLink (156)
Ss7 M3ua Sap
ss7SigLink (156)
Ss7 M3ua Psp
ss7SigLink (156)
Ss7 M3ua Psrv
ss7SigLink (156)
Ss7 Mtp2 Link
SNMP traps
The SNMP traps module of TelcoBridges products monitor the operation status of some MIBS OIDs and generates notifications when the states change. The default monitoring polling period is set to 1 minute. This value can be modified in the SNMP configuration.
SNMP Trap/Notification
linkDown
IF-MIB
1.3.6.1.6.3.1.1.5.3
{ ifIndex, ifAdminStatus, ifOperStatus, ifDescr }
When ifAdminStatus=1 & ifOperStatus=2, In certain conditions could be critical, this trap should raise an alarm.
RFC1573
2.8+
linkUp
IF-MIB
1.3.6.1.6.3.1.1.5.4
{ ifIndex, ifAdminStatus, ifOperStatus, ifDescr }
Transition from network interface Down state. Normal clear trap for linkDown alarm
RFC1573
2.8+
ColdStart
IF-MIB
1.3.6.1.6.3.1.1.5.1
{ OID }
This is sent when snmp service is started. tbAppState and tbAppHaState already covers this case with tbsnmpagent. Please disregard.
RFC3418
3.2+
WarmStart
IF-MIB
1.3.6.1.6.3.1.1.5.2
{ OID }
This is sent when snmp service is restarted. tbAppState and tbAppHaState already covers this case with tbsnmpagent. Please disregard.
RFC3418
3.2+
nsNotifyStart
NET-SNMP-MIB
1.3.6.1.4.1.8072.4.0.1
{ OID }
This is sent when snmp service is started. tbAppState and tbAppHaState already covers this case with tbsnmpagent. Please disregard.
www.net-snmp.org
3.2+
nsNotifyShutdown
NET-SNMP-MIB
1.3.6.1.4.1.8072.4.0.2
{ OID }
This is sent when snmp service is stopped. tbAppState and tbAppHaState already covers this case with tbsnmpagent. Please disregard.
www.net-snmp.org
3.2+
nsNotifyRestart
NET-SNMP-MIB
1.3.6.1.4.1.8072.4.0.3
{ OID }
This is sent when snmp service is restarted. tbAppState and tbAppHaState already covers this case with tbsnmpagent. Please disregard.
www.net-snmp.org
3.2+
tbNapAvailability
The network access point has a new percentage of availability for calls # For TDM networks (tbNapSignalingType=isdn(1), ss7(2), casr2(6)) this means there are a percentage of channels available for calls. ss7 includes sigtran signaling type. # For SIP networks (tbNapSignalingType=sip(3)), this means the remote SIP device is answering or not SIP OPTIONS polling messages and calls can be or can`t be made to this network. # When using H.248 (tbNapSignalingType=tdmMedia(5), voipMedia(4)) this means there are TDM channels or RTP ports available or not for calls.
1.3.6.1.4.1.21776.1.1.2.1.0.1
{ tbNapName, tbNapSignalingType, tbNapAvailablePercent }
When tbNapAvailablePercent=0
2.8+
tbPwrSupplyState
The redundant power supply has a new state. tbHwPwrSupplyStatus can be: good(0) failure(1)
1.3.6.1.4.1.21776.1.1.2.1.0.2
{ tbHwPwrSupplyName, tbHwPwrSupplyStatus }
When tbHwPwrSupplyStatus=1
2.8+
tbNp1State
The N+1 patch panel has a new state. tbHaNp1FunctionalState can be: unknown(-1) fault(0): There is no access to the N+1 patch panel unprotected(1): Standby unit is not available unprotectedSwitched(2): Standby unit is active and replaced primary unit is not ready to take over healthy(3): N+1 unit is normal and standby unit is available healthySwitched(4): N+1 unit is switched to the standby unit and replaced primary is available
1.3.6.1.4.1.21776.1.1.2.1.0.3
{ tbHaNp1Name, tbHaNp1FunctionalState }
When tbHaNp1FunctionalState=0 OR tbHaNp1FunctionalState=1 OR tbHaNp1FunctionalState=2, it is major.
2.8+
tbAppState
This toolpack application has a new state. tbHaAppCurrentState can be: unknown(100) notRunning(101) starting(102) ready(103) shuttingDown(104) goingManagement(105) fault(106)
1.3.6.1.4.1.21776.1.1.2.1.0.4
{ tbHaAppName, tbHaAppCurrentState, tbHaAppHostName }
All tbHaAppCurrentState states are alarms except 103
2.8+
tbAppHaState
This toolpack high availability application has changed state. tbHaAppHaCurrentState can be: notPresent(0) active(1) standby(2)
1.3.6.1.4.1.21776.1.1.2.1.0.5
{ tbHaAppName, tbHaAppHaCurrentState, tbHaAppHostName }
Normal starting process of services will begin with tbHaAppHaCurrentState with value 0 (notPresent), going to Value 2 (standby) to finally Value 1 (active). Consider as an alarm if tbHaAppHaCurrentState of services stay consistently in others states different than 1, this applies for standalone and 1+1 systems.
2.8+
tbClkGradeState
The network synchronization clock from this interface has a new grade. tbClockType can be: none(1) osc(2) trunk(3) netRef1(4) netRef2(5) ptmc1(6) ptmc2(7) ct8a(8) ct8b(9) mbl(10) bits(11) ds3(12) sonetSdh(13) holdover(14) tbClockGrade can be: unqualified(0) beingQualified(1) qualified(2) qualifiedForRecovery(3)
1.3.6.1.4.1.21776.1.1.2.1.0.6
{ tbClockName, tbClockType, tbClockGrade }
When Object 'tbClockGrade=0' or 'tbClockGrade=1' Cleared by 'tbClockGrade=2' or 'tbClockGrade=3'
2.8+
tbClkActiveState
This interface has been selected or not to provide the network synchronization clock for the whole system. tbClockActive can be: no(0) yes(1)
1.3.6.1.4.1.21776.1.1.2.1.0.7
{ tbClockName, tbClockType, tbClockActive }
When ALL OBJECTS report tbClockActive=0
2.8+
tbIsdnDChannelState
The signaling channel for this ISDN interface has changed. tbIsdnDChannelUp can be: no(0) yes(1)
1.3.6.1.4.1.21776.1.1.2.1.0.8
{ tbIsdnDescription, tbIsdnDChannelUp }
When tbIsdnDChannelUp=0
2.8+
tbCASPhysicalLineState
The interface for this CAS stack has changed. tbCasPhysicalLineUp can be: no(0) yes(1)
1.3.6.1.4.1.21776.1.1.2.1.0.9
{ tbCasDescription, tbCasPhysicalLineUp }
When tbCasPhysicalLineUp=0
2.8+
tbSipState
The SIP stack state has changed. tbSipCurrentState can be: no(0) yes(1)
1.3.6.1.4.1.21776.1.1.2.1.0.10
{ tbSipDescription, tbSipCurrentState }
When tbSipCurrentState=0
2.8+
tbH248MgcState
The H.248 communication state between this unit and the Media Gateway Controller has changed. tbH248MgcCurrentState can be: up(1) down(2) unknown(3)
1.3.6.1.4.1.21776.1.1.2.1.0.11
{ tbH248MgcName, tbH248MgcCurrentState }
When tbH248MgcCurrentState=2 OR tbH248MgcCurrentState=3
2.8+
tbHostUpdateAvailableState
The availability state of the host update has changed. tbHostUpdateAvailable can be: false(0) true(1) notSupported(2) unknown(3) disabled(4)
1.3.6.1.4.1.21776.1.1.2.1.0.12
{ tbHostName, tbHostUpdateAvailable }
__
2.8+
Example of packet capture: tcpdump port 162 -i mgmt0 -s 0 tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on mgmt0, link-type EN10MB (Ethernet), capture size 65535 bytes 14:08:51.491789 IP 10.7.0.13.37452 > 10.7.0.221.snmptrap: V2Trap(144) system.sysUpTime.0=9546160 S:1.1.4.1.0=S:1.1.5.4 interfaces.ifTable.ifEntry.ifIndex.452160.26=26 interfaces.ifTable.ifEntry.ifAdminStatus.452160.26=1 interfaces.ifTable.ifEntry.ifOperStatus.452160.26=1 S:1.1.4.3.0=E:8072.3.2.10
Note
The ifIndex is a random value that can change after configuring the system, or adding new elements. This should not be relied on as a reference value. Please use the ifDescr instead.
SNMP SET
The SNMP SET command is not supported by TelcoBridges products. However, a RESTful API can be used to change the configuration remotely.
Configuration
Helpful resources
External Sources
In this section
Last updated
Was this helpful?

